Forgot password?

Create an account!

Forum

« back

RhinoScript – about array library

Messages

Please log in to write a message.

  • 4. Hanno (Aug 08, 2008 13.31):

    Hi Javier,

    Johannes is right, you don't need to put the array library somewhere special, you just have to run it once before you run any script that uses it - Rhino remembers every function that has been declared until you close it, and because of this it is possible to collect useful functions in "library scripts" that don't do anything but providing these functions to other scripts.

    But I think the problem was not the country settingy but simply the fact that the srf slope script did not work with your surface. I wrote it for an architectural project where I had only surfaces that were lofted between two curves. It does work with more than that, but there are certainly limitations. So I think on the other machine you just had a "better" surface...

    Greetings

    Hanno

  • 3. tovarna (Aug 08, 2008 13.20):

    the script i am trying says its needs library 1.3 i load it and it still doesn't work. i tried also loading it on startup.
    then i tried in other computer and it worked fine. i think it was country settings of the computer or something lik that.
    HEY HEY!
    Many thanks Johannes for such fast answer! Now i don't feel alone

  • 2. Johannes (Aug 08, 2008 12.57):

    Hi Javier,
    i think that the libraries are missing.

    First you have to download all required libraries. Then you can just open the library and run it like a "normal" script. After that all functions from the library are availible and you can run your script like "20080702_Tool_surface slope gradient_v1.1.rvb".

    In Rhino you have also the option to start scripts like libraries together with Rhino. You will find that in your RhinoOptions -> RhinoScript -> StartUp.

    Johannes

  • 1. tovarna (Aug 08, 2008 11.50):

    hi. i am new...(mean NEW) user or rhino, and i have started because i just saw what scripting was. so i am trying to understand the book rhinoscript101. meanwhile i am trying your scripts and some other web sites (specially theverymany.com). i just don't what is going wrong with some of the scripts i got. maybe i don't load the array library correctly. should i put it in some specific folder?
    to me more...exact. i have tried 20080807_Tool_LaserHelper_v1.rvb and goes fine. but 20080702_Tool_surface slope gradient_v1.1.rvb says "mismatch 'ubound' line 462 (which it doesn't have so many). Too newie to try these things?
    thanks in advance
    Javier, from Spain

Recommend

Why are these buttons gray?